MySQL和mysql-connector-java、Java的版本问题

背景:

很多刚使用MySQL的小伙伴都会遇到一个问题,那就是mysql-connector-java、Java与MySQL数据库的版本不对应,从而导致某些数据库的操作报错。

mysql-connector-java、Java与MySQL的版本对应该系:

  • 英文版:

    Summary of Connector/J Versions:

    Connector/J version JDBC version MySQL Server version JRE Required JDK Required for Compilation Status
    5.1 3.0, 4.0, 4.1, 4.2 5.61, 5.71, 8.01 JRE 5 or higher1 JDK 5.0 AND JDK 8.0 or higher2,3 General availability
    8.0 4.2 5.6, 5.7, 8.0 JRE 8 or higher JDK 8.0 or higher2 General availability. Recommended version.
  • 中文版

    连接器/J 版本摘要‎:

    Connector/J 版本 JDBC 版本 MySQL Server 版本 JRE 所需 JDK 编译所需 说明
    5.1 3.0, 4.0, 4.1, 4.2 5.61, 5.71, 8.01 JRE 5 或更高版本 JDK 5.0和JDK 8.0或更高版本 一般可用性
    8.0 4.2 5.6, 5.7, 8.0 JRE 8 或更高版本 JDK 8.0或更高版本 一般可用性,推荐版本
  • ps:Connector/J 版本即为mysql-connector-java版本

Note(注意):

  • MySQL Connector/J 8.0 is highly recommended for use with MySQL Server 8.0, 5.7, and 5.6. Please upgrade to MySQL Connector/J 8.0.(强烈推荐使用 MySQL 服务器 8.0、5.7 和 5.6 的 MySQL 连接器/J 8.0。请升级到 MySQL 连接器/J 8.0。)
  • JRE 8 or higher is required for Connector/J 5.1 to connect to MySQL 5.6, 5.7, and 8.0 with SSL/TLS when using some cipher suites.( 使用某些密码套件时,连接器/J 5.1 需要 JRE 8 或更高,才能使用 SSL/TLS 连接到 MySQL 5.6、5.7 和 8.0。)
  • A customized JSSE provider might be required to use some later TLS versions and cipher suites when connecting to MySQL servers. For example, because Oracle's Java 8 is shipped with a JSSE implementation that only supports TLSv1.2 and lower, you need a customized JSSE implementation to use TLSv1.3 on Oracle's Java 8 platform.(连接到 MySQL 服务器时,可能需要自定义的 JSSE 提供商使用一些较晚的 TLS 版本和密码套件。例如,由于甲骨文的 Java 8 附带仅支持 TLSv1.2 和更低的 JSSE 实现,因此您需要自定义的 JSSE 实现才能在甲骨文的 Java 8 平台上使用 TLSv1.3。)
  • If you are building Connector/J 5.1 from source code using the source distribution, you must have both JDK 8.0 or higher AND JDK 5.0 installed. It is also good to have JRE 6 for compiling Connector/J 5.1.(如果您使用源分布从源代码构建连接器/J 5.1,则必须同时安装 JDK 8.0 或更高JDK 5.0。它也是很好的JRE 6编译连接器/J 5.1。)

参考文档:

点赞

发表评论

电子邮件地址不会被公开。必填项已用 * 标注